Back to Microblink home page

Follow

iOS: linker command failed with exit code 1

ERROR

clang: error: linker command failed with exit code 1 (use -v to see invocation)

 
SOLUTION:
 
Please ensure that you have a MicroBlink file in the MicroBlink.framework folder and that file has approximately 100MB
  
 
Type in the terminal >file link-to-the-MicroBlink
Example: file /Users/ivanculo/Microblink/blinkid-phonegap/BlinkID/src/ios/blinkid-ios/MicroBlink.framework/MicroBlink
 
You should obtain following result:
> /Users/ivanculo/Microblink/blinkid-phonegap/BlinkID/src/ios/blinkid-ios/MicroBlink.framework/MicroBlink: Mach-O universal binary with 5 architectures: [i386: Mach-O dynamically linked shared library i386] [x86_64] [arm_v7] [arm_v7s] [arm64]
> /Users/ivanculo/Microblink/blinkid-phonegap/BlinkID/src/ios/blinkid-ios/MicroBlink.framework/MicroBlink (for architecture i386):    Mach-O dynamically linked shared library i386
> /Users/ivanculo/Microblink/blinkid-phonegap/BlinkID/src/ios/blinkid-ios/MicroBlink.framework/MicroBlink (for architecture x86_64):  Mach-O 64-bit dynamically linked shared library x86_64
> /Users/ivanculo/Microblink/blinkid-phonegap/BlinkID/src/ios/blinkid-ios/MicroBlink.framework/MicroBlink (for architecture armv7):   Mach-O dynamically linked shared library arm_v7
> /Users/ivanculo/Microblink/blinkid-phonegap/BlinkID/src/ios/blinkid-ios/MicroBlink.framework/MicroBlink (for architecture armv7s):  Mach-O dynamically linked shared library arm_v7s
> /Users/ivanculo/Microblink/blinkid-phonegap/BlinkID/src/ios/blinkid-ios/MicroBlink.framework/MicroBlink (for architecture arm64):   Mach-O 64-bit dynamically linked shared library arm64
If you receive any other output, like:
 
$ file blinkid-phonegap/BlinkID/src/ios/blinkid-ios/MicroBlink.framework/MicroBlink
blinkid-phonegap/BlinkID/src/ios/blinkid-ios/MicroBlink.framework/MicroBlink: ASCII text
version https://git-lfs.github.com/spec/v1
oid sha256:f970ba88bfe75f06c30f766d9f0939b7d82db0e750828c22fd99d88e34600209
size 100857360
 
 
In the terminal, please position to our repo and explicitly fetch everything from git-lfs:
 
>cd blinkid-phonegap/BlinkID/src/ios/blinkid-ios
>git lfs pull
 
Now please remove the old plugin from the project and import a new one. 
 
Was this article helpful?
0 out of 0 found this helpful
Have more questions? Submit a request

Comments

Powered by Zendesk